This chapter describes how to install the Polymer 3.0 tools and get started with a template Polymer 3.0 project.

To set up a development environment for Polymer 3.0:

Download and run a Git installer for your operating system.

See the Git documentation for detailed instructions on installing Git.

To confirm that Git is correctly installed:

git --version

Download and run a Node.js installer for your operating system. This will install npm as well.

For more detailed instructions on installing npm and Node.js, see the npm and Node.js install documentation.

Install a current or active LTS version of Node.js. Polymer requires a current or active LTS version of Node.js. See our Node.js support page for more information.

To confirm that npm is correctly installed:

npm --version

To confirm that Node.js is correctly installed:

node --version

To install Polymer CLI, run the following command:

npm install -g polymer-cli

To confirm that the Polymer CLI has been correctly installed:

polymer --version

To test your Polymer development environment, you can try out a sample Polymer app we prepared earlier:

git clone https://github.com/PolymerLabs/start-polymer3.git
cd start-polymer3
npm install
polymer serve

For more information on the tools and options in the Polymer CLI, see the documentation on Polymer CLI commands.